Содержание

Введение

Настройка программы

Работа с носителями информации

Работа с регистраторами

Работа с водителями

Работа с типами автомобилей

Работа с автомобилями

Работа с заданиями

Детальная информация задания

Графики

Резервное копирование и обмен информацией

Технологический контроль


Введение

Система регистрации параметров автомобилей "VARSys" - это комплекс аппаратно-программных средств, предназначенных для регистрации и анализу работы автомобиля, позволяющий существенно повысить экономическую рентабельность эксплуатации каждого автомобиля и автомобильного парка в целом.

Система позволяет регистрировать следующие параметры автомобиля:

  • уровень топлива в баках;
  • скорость движения автомобиля;
  • частоту вращения двигателя;
  • напряжение бортовой сети;
  • температуру в салоне автомобиля.

Кроме непосредственно регистрируемых параметров, система производит анализ данных и определяет:

  • средний расход топлива (л/100 км);
  • количество и общий объем заправок топлива;
  • количество и общий объем сливов топлива;
  • время работы двигателя;
  • время движения автомобиля;
  • максимальную скорость движения;
  • максимальные обороты двигателя.

Система состоит из:

  • регистратора;
  • носителя информации;
  • комплекта подключения к персональному компьютеру (адаптер, блок питания, кабель);
  • программы обработки данных (в дальнейшем - программа).

Работа программы основана на обработке "заданий", выдаваемых на рейс или период работы автомобиля. Информация о созданном задании записывается в носитель информации, который затем вставляется в регистратор автомобиля и служит для накопления регистрируемой информации. После завершения рейса (периода работы) носитель подключается к компьютеру и программа считывает и анализирует информацию о работе автомобиля за период выполнения задания.

Система создана таким образом, что регистратор будет записывать информацию в носитель, и, соответственно, эта информация будет считана компьютером, только если носитель имеет задание на работу или градуировку для ДАННОГО РЕГИСТРАТОРЫ. Таким образом исключена подмена носителей или регистраторов с целью обмана.

В своей работе программа использует информацию о каждом автомобиле, на котором установлен регистратор, поэтому, перед работой с тем или иным автомобилем информация о нем должна быть введена в базу данных программы.


Автомобили

Все автомобили, на которые устанавливают регистраторы необходимо вносить в базу данных программы.

Просмотреть, изменить или удалить информацию об автомобилях можно в окне "Автомобили", открываемого через пункт меню "Автомобили"|"Список автомобилей" или выбором пункта "Автомобили" на вкладке "Автомобили" скользящего меню слева в главном окне программы.

Для добавления автомобиля в базу данных в окне "Автомобили" следует нажать кнопку "Создать". При этом форма переходит в режим ввода информации о новом автомобиле. Следует заполнить нужные поля данных, после чего надо нажать кнопку "Добавить". Информация занесется в базу данных и отобразится в таблице. Для выхода из режима ввода без сохранения информации следует нажать кнопку "Обновить" или выбрать в таблицы другую строку.

При выборе типа автомобиля из предлагаемого выпадающего списка все поля данных заполняются значениями, указанными в выбранном типе автомобиля. После этого эти значения можно изменить, чтобы настроить данные конкретного автомобиля.

Серийный номер установленного регистратора следует выбирать из предлагаемого выпадающего списка, в котором отображаются регистраторы, имеющиеся в базе данных программы и не установленные на автомобили (по информации в базе данных). Таким образом исключается возможность ввода некорректного регистратора.

Для изменения информации об автомобиле следует выбрать соответствующую строку в таблице и изменить информацию, после чего нажать кнопку "Изменить". Для возврата к прежней информации (действует только до нажатия кнопки "Изменить") следует нажать кнопку "Обновить".

Для удаления автомобиля из базы данных следует в таблицы выбрать соответствующую строку и нажать кнопку "Удалить".

Аавтомобиль имеет следующие характеристики (поля данных):

  • Госномер: гос. номер автомобиля
  • Тип автомобиля: название типа автомобиля, под которым он будет храниться в базе данных программы
  • Используется: признак эксплуатации автомобиля в текущее время

Вкладка "Характеристика":

  • Объем бака 1: объем основного топливного бака автомобиля (в литрах)
  • Объем бака 2: объем дополнительного топливного бака автомобиля (в литрах); если он отсутствует, то значение должно быть 0
  • Критерий заправки: разница в объеме топлива (в литрах), по которому программа определят факт заправки топлива; рекомендуется устанавливать порядка 5-10% от объема бака
  • Критерий заправки: разница в объеме топлива (в литрах), по которому программа определят факт слива топлива; рекомендуется устанавливать порядка 5-10% от объема бака
  • Расход: среднее значение расхода топлива при движении автомобиля (в литрах)
  • Напряжение: напряжение бортовой сети автомобиля (в В)
  • Метод измерения уровня: метод определения уровня топлива
  • Учитывать напряжение: если установлена галочка, то при определении уровня топлива учитывается текущее напряжение бортовой сети (действительно только при методе измерения по напряжению)

Вкладка "Оборудование":

  • Спидометр - Тип: тип датчика спидометра, например, для автомобилей Газель - "обычный имп./частотный", а для КАМАЗ - "обычный имп./частотный с понижен. порогом"
  • Коэф. пересчета (имп./км): количество импульсов на один км пути
  • Тахометр - Тип: тип датчика частоты оборотов двигателя, например, для ВАЗ - "Обычный имп./частотный", а для КАМАЗ - "обычный имп./частотный с понижен. порогом"
  • Коэф. пересчета (имп./об.): количество импульсов на один оборот двигателя
  • Мин. об./мин: минимальные обороты двигателя (об./мин)
  • Макс. об./мин: максимально допустимые обороты двигателя (об./мин); используется для определения работы двигателя на недопустимых режимах
  • Макс. об. ХХ/мин: максимальные обороты холостого хода двигателя (об./мин); используется для определения работы двигателя на холостом ходу и движения автомобиля накатом
  • Опт. об./мин: оптимальные обороты двигателя (об./мин)

Вкладка "Регистратор":

  • Серийный номер: серийный номер регистратора, установленного на автомобиле
  • Дата установки: дата установки регистратора на автомобиль

Вкладка "Градуировка":

  • Градуировка выполнена/Нет данных градуировки: признак наличия/отсутствия градуировочной характеристики
  • Дата выдачи задания на градуировку
  • Дата чтения данных градуировки

Вкладка "Описание": комментарии к данному автомобилю.

Окно "Автомобили" можно закрыть, нажав кнопку "Закрыть".


Градуировка автомобиля

Для правильного определения уровня топлива в баках автомобиля перед эксплуатацией системы после установки регистратора на автомобиль необходимо произвести градуировку баков автомобиля. В ходе градуировки определяется градуировочная характеристика, т.е. соответствие измеренного значения датчика уровня.

Внимание! Проведение градуировки уничтожает предыдущую градуировку данного автомобиля (если она была проведена)!

Для выполнения градуировки следует подключить носитель, не содержащий нужных данных, к компьютеру через адаптер, открыть окно "Автомобили" и на вкладке "Градуировка" нажать кнопку "Выполнить град.". При этом производится запись задания на градуировку выбранного автомобиля в носитель. Внимание! Все данные на подключенном носителе будут уничтожены! После записи в носитель программа автоматически предлагает напечать бланк градуировки. При утвердительном ответе на этот запрос выполняется печать бланка.

Внимание! Регистратор работает только с носителем, имеющим задание на работу или градуировку для данного регистратора! Аналогично, программа не будет обрабатывать данные носителя, записанные не заданным регистратором.

Градуировочная характеристика бака строится по эталонным точкам, в которых точно известно количество топлива в баке. Для создания градуировочной характеристики необходимо иметь не менее двух точек, однако, от количество эталонных точек напрямую зависит точность работы всей системы по контролю уровня топлива. Поэтому рекомендуется при проведении градуировки делать не менее 5 точек, причем желательно первую и последнюю точки делать при полностью пустом и полностью полном баке.

После проведения градуировки следует подключить носитель к компьютеру через адаптер. Программа должна автоматически считать информацию из носителя и открыть окно "Градуировка датчиков".

В левой части окна в таблице отображаются эталонные точки, считанные из носителя. Их порядок соответствует порядку нажатий на кнопку регистратора. В правой части окна отображается полученная градуировочная характеристика. Если в окне отображается новая характеристика (только что считанная из носителя), то все значения объема топлива будут равны 0. Эти значения топлива надо ввести в таблицу, для чего нужно выбрать требуемую точку (соответствующую строку в таблице) и нажать клавишу ENTER или выполнить двойной щелчок мышкой на этой строке. В открывшемся окне ввода следует ввести объем топлива в баке, соответствующий данной точке, и нажать кнопку "Ок". При этом на графике отображается новое значение точки.

Если градуировка была выполнена таким образом, что точки градуировки не соответствуют нулевому и максимальному (полному баку) значениям уровня топлива, то на графике отображаются дополнительные точки, соответствующие этим значениям.

Если строка в таблице подсвечивается красным цветом, это значит, что зажигание не было включено, т.е. эталонная точка некорректна. Для удаления ошибочной точки следует ее выделить в таблице и нажать кнопку "Удалить".

После ввода всех эталонных точек следует нажать кнопку "Сохранить".

Редактирование эталонных точек и их удаление доступно только при создании градуировочной характеристики до закрытия этого окна. При просмотре существующей характеристики эти функции недоступны.

Просмотр существующей градуировочной характеристики производится в этом же окне, открываемом кнопкой "Показать результ.", расположенной на вкладке "Градуировка" окна "Автомобили" или кнопкой "Градуировка" окна информации об устройствах "Регистратор".

Закрыть окно "Градуировка датчиков" можно нажатием кнопки "Закрыть".

При установке галочки в поле Показать значения на графике отображаются значения каждой точки градуировочной характеристики.


Типы автомобилей

Информация о характеристике типа автомобиля храниться в базе данных программы и позволяет упростить добавление новых автомобилей марок, уже имеющихся в базе данных. В программе "тип автомобиля" - это набор параметров автомобиля (объем топливных баков, тип датчика спидометра и т.д.) которые применяются по умолчанию при создании нового автомобиля в программе. Поэтому удобнее вначале описать нужные типы автомобилей, а потом на их основе вносить автомобили в базу данных.

Окно "Типы автомобилей" открывается пунктом меню "Автомобили"|"Список типов автомобилей" или выбором пункта "Типы автомобилей" на вкладке "Автомобили" скользящего меню слева в главном окне программы.

В верхней части этого окна в таблице отображаются все имеющиеся в базе данных программы типы автомобилей. В нижней части окна отображается информация о выбранном в таблице типе автомобиля.

Для добавления типа автомобиля в базу данных следует нажать кнопку "Создать". При этом окно переходит в режим ввода информации о новом автомобиле и устанавливает значения по умолчанию. Следует заполнить нужные поля данных, после чего надо нажать кнопку "Добавить". Информация занесется в базу данных и отобразится в таблице. Для выхода из режима ввода без сохранения информации следует нажать кнопку "Обновить" или выбрать в таблицы другую строку.

Для изменения информации о типе автомобиля следует выбрать соответствующую строку в таблице и изменить информацию, после чего нажать кнопку "Изменить". Для возврата к прежней информации (действует только до нажатия кнопки "Изменить") следует нажать кнопку "Обновить".

Для удаления типа автомобиля из базы данных следует в таблицы выбрать соответствующую строку и нажать кнопку "Удалить".

Тип автомобиля имеет следующие характеристики (поля данных):

  • Марка: название типа автомобиля, под которым он будет храниться в базе данных программы

Вкладка "Топливо":

  • Объем бака 1: объем основного топливного бака автомобиля (в литрах)
  • Объем бака 2: объем дополнительного топливного бака автомобиля (в литрах); если он отсутствует, то значение должно быть 0
  • Критерий заправки: разница в объеме топлива (в литрах), по которому программа определят факт заправки топлива; рекомендуется устанавливать порядка 5-10% от объема бака
  • Критерий заправки: разница в объеме топлива (в литрах), по которому программа определят факт слива топлива; рекомендуется устанавливать порядка 5-10% от объема бака
  • Расход на 100 км: среднее значение расхода топлива при движении автомобиля (в литрах)
  • Напряжение сети: напряжение бортовой сети автомобиля (в В)
  • Метод измерения уровня: метод определения уровня топлива
  • Учитывать напряжение: если установлена галочка, то при определении уровня топлива учитывается текущее напряжение бортовой сети (действительно только при методе измерения по напряжению)

Вкладка "Скорость и путь":

  • Тип датчика спидометра: тип датчика, например, для автомобилей Газель - "обычный имп./частотный", а для КАМАЗ - "обычный имп./частотный с понижен. порогом"
  • Коэф. пересчета (имп./км): количество импульсов на один км пути

Вкладка "Работа двигателя ":

  • Тип тахометра: тип датчика частоты оборотов двигателя, например, для ВАЗ - "Обычный имп./частотный", а для КАМАЗ - "обычный имп./частотный с понижен. порогом"
  • Коэф. пересчета (имп./об.): количество импульсов на один оборот двигателя
  • Мин. обороты двиг.: минимальные обороты двигателя (об./мин)
  • Макс. обороты двиг: максимально допустимые обороты двигателя (об./мин); используется для определения работы двигателя на недопустимых режимах
  • Макс. обороты ХХ: максимальные обороты холостого хода двигателя (об./мин); используется для определения работы двигателя на холостом ходу и движения автомобиля накатом
  • Оптим. обороты двиг.: оптимальные обороты двигателя (об./мин)

Вкладка "Описание": комментарии к типу автомобиля

Окно "Типы автомобилей" можно закрыть, нажав кнопку "Закрыть".


Задания

Для регистрации параметров автомобилей в процессе эксплуатации программой в носитель информации записывается "задание", содержащее информацию о рейсе (периоде работы) данного автомобиля. Эта же информация помещается в базу данных программы. Таким образом, все данные о работе всех автомобилей разделены на "задания".

Управлять списком заданий можно в окне "Задания", открываемого через пункт меню "Задания"|"Список заданий" или выбором пункта "Список заданий" на вкладке "Задания" скользящего меню слева в главном окне программы.

В верхней части окна расположен список всех заданий, имеющихся в базе данных программы. Ниже его имеются поля для отображения уточняющей информации о выбранном (в списке) задании: описание маршрута, список водителей и описание задания.

Щелчок мышкой по какому-либо заголовку колонки таблицы приводит к сортировке списка заданий по этой колонке, что индицируют серый цвет всей колонки и значок в заголовке колонки.

Задания могут быть:

  • создано: созданное задание, но не записанное в носитель;
  • выдано: задание записано в носитель;
  • считано: считана информация о работе автомобиля по данному заданию. Задание не считается завершенным;
  • выполнено: информация работе автомобиля по данному заданию считана из носителя и задание считается завершенным.

В списке заданий розовым цветом подсвечиваются не выполненные задания, а зеленым - выполненные.

Для создания нового задания в окне "Задания" следует нажать кнопку "Новое". При этом открывается новое окно детальной информации задания с полями данных, подготовленными для ввода информации.

Для просмотра детальной информации о существующем задании нужно в списке заданий выбрать интересующее и нажать кнопку "Показать" или дважды щелкнуть мышкой по нужной строке списка. При этом открывается окно детальной информации задания, в котором отображается вся необходимая информация.

Для удаления задания из базы данных следует в таблицы выбрать соответствующую строку и нажать кнопку "Удалить".

Кнопка "Обновить" служит для обновления информации в списке заданий и в уточняющих полях, если эта информация могла быть изменена вне этого окна.

Окно "Задания" можно закрыть, нажав кнопку "Закрыть".

Для удобства поиска нужного задания в списке имеется возможность фильтрации списка заданий. Окно выбора фильтра открывается кнопкой "Окно фильтра":

В этом окне можно задать определенные критерии показа заданий. Если установить значимые критерии (например, не "---") и нажать кнопку "Применить", то в окне "Задания" в списке заданий будут отображены только те, которые удовлетворяют этим критериям. При этом, под списком заданий надпись зеленого цвета "Фильтр: нет" изменится на надпись красного цвета с указанными критериями фильтрации. Фильтр можно отменить, нажав кнопку "Отмена" окна "Фильтр заданий".


Детальная информация задания

Окно детальной информации задания отображает информацию о самом задании, статистическую информацию по регистрируемым данным, графики контролируемых параметров автомобиля за отчетный период.

На этапе создания задания (до его выдачи в носитель) для редактирования доступны следующие поля данных:

  • Гос.номер автомобиля
  • Номер путевого листа
  • Дата выдачи путевого листа
  • Даты начала и конца отчетного периода
  • Маршрут: описание маршрута движения
  • Расстояние по карте (км)
  • Дата создания задания и сотрудник его создавший
  • Водители: можно указать до четырех водителей
  • Описание: комментарии к заданию

Кроме поля Гос.номер автомобиля, которое является обязательным, остальные поля заполняются по желанию оператора.

При нажатии на кнопку "Сохранить" новое задание сохраняется в базе данных. Если закрыть окно без сохранения, то вся задание не добавиться в базу данных!.

В дальнейшем, можно открывать окно детальной информации для данного задания и редактировать эту информацию.

Редактирование данных задания возможно только до выдачи его в носитель!

Для выдачи задания в носитель следует подключить его к компьютеру (через адаптер), открыть окно детальной информации требуемого задания (если оно было создано заранее) или создать задание и заполнить нужные поля. Затем нажать кнопку "Выдать", при этом производится сохранения информации о задании в базе данных и запись задания в носитель. После успешной выдачи задания обновляются поля Серийный номер носителя и Дата инициализации носителя на вкладке Регистратор.

Внимание! При записи нового задания в носитель программа производит синхронизацию часов носителя с часами компьютера. Поэтому, периодически следует проверять правильность показаний системных часов компьютера средствами MS Windows.

Внимание! При записи нового задания в носитель вся прежняя информация в носителе уничтожается!

Внимание! Регистратор работает только с носителем, имеющим задание на работу или градуировку для данного регистратора! Аналогично, программа не будет обрабатывать данные носителя, записанные не заданным регистратором.

При желании прочитать информацию из носителя, содержащего данные регистрации, следует подключить его к компьютеру через адаптер. Программа автоматически открывает окно информации о задании (если находит соответствующее задание в базе данных) или предлагает добавить считанное задание в базу данных. При нажатии на кнопку "Чтение" производится считывание протокола регистрации из носителя, обработка полученных данных, заполнение полей в окне детальной информации. Считанные данные сохраняются в файле, имя которого отображается в поле Файл данных. После чтения данных из носителя программа заполняет отчетные поля данных, отображающие статистическую информацию о работе автомобиля. На вкладке "Графики" выводятся графики за отчетный период. Поле Количество отключений содержит общее число отключений носителя от регистратора или пропадания питания на регистраторе (отключения регистратора) за отчетный период.

Чтение данных из носителя не приводит к какому-либо изменению информации в носителе или базе данных (до нажатия кнопки "Сохранить" и "Выполнено").

Для более подробного изучения графиков работы автомобиля следует открыть специальное окно "Графики", для чего на вкладке "Графики" окна детальной информации следует нажать кнопку

Информацию о задании вместе с графиками можно просмотреть и распечатать на принтере в виде отчета. Для этого следует нажать кнопку "Отчет", после чего откроется окно просмотра отчета.

Для завершения задания следует нажать кнопку "Выполнено". При этом состояние задания становится "выполнено", заполняется поле даты закрытия, корректируются даты отчетного периода задания; после чего сохраняются все данные в базе данных и в файле данных.

Закрыть окно можно, нажав кнопку "Закрыть".


Графики

В окне графиков отображаются графики регистрируемых параметров автомобиля за отчетное время задания. Окно открывается нажатием на кнопку [image], расположенную на вкладке "Графики" окна детальной информации задания.

В левой части окна графиков расположена панель выбора отображаемых графиков, на которой расположены кнопки:

  • Скорость: кнопка отображение графика скорость/время
  • Бак 1: кнопка отображения графика уровень топлива в баке 1/время
  • Бак 2: кнопка отображения графика уровень топлива в баке 2/время
  • Баки все: кнопка отображения графика уровень топлива в обоих баках/время
  • Об./мин: кнопка отображения графика частота вращения двигателя/время
  • Пробег: кнопка отображения графика пройденное расстояние/время
  • Расход: кнопка отображения графика общий уровень топлива/пройденное расстояние

В зависимости от наличия того или иного оборудования на автомобиле, отдельные кнопки могут быть запрещены; так, например, при отсутствии датчика спидометра будут запрещены кнопки Скорость, Пробег и Расход.

Названия кнопок будут отображаться, если в настройках программы опция Показывать надписи кнопок включена.

Нажатие на кнопку вызывает отображение соответствующего графика в окне. Положение кнопки (нажатая/отпущенная) индицирует отображение соответствующего ей графика. Если какой-либо график отображается (кнопка нажата) и нажать кнопку еще раз, данный график скроется.

Для отображения графиков окно имеет две панели: верхнюю и нижнюю. Таким образом, одновременно в окне могут отображаться один или два графика (или не отображаться ни одного). Графики выводятся в порядке расположения кнопок, кроме этого, в окне отображаются два ПОСЛЕДНИХ графика (по нажатиям кнопок выбора); например, если нажать кнопки Бак 1, Скорость, Пробег и Об./мин, то в окне будет два графика: обороты и пробег, причем, график оборотов будет расположен выше (соответствующая кнопка расположена выше кнопки Пробег).

Также слева расположена кнопка Поиск даты, нажатие на которую приводит к появлению окна выбора даты. Если в этом окне выбрать какую-либо дату, входящую в отчетный период задания, то видимые графики, зависящие от времени (кроме графика Уровень/Пробег) установятся таким образом, что по середине окна будет выбранная дата, а масштаб по времени будет три дня (плюс-минус один день).

Кнопка Информ позволяет отображать/скрывать панель информации о выбранном интервале времени. Если данная панель отображается, то в нее выводится информация о интервале времени, отображаемом на графиках. Эта информация оперативно меняется при прокрутке, увеличении или уменьшении графиков. Информация о выбранном интервале времени аналогична информации в окне детальной информации задания, но за выбранный отрезок времени.

Внимание! Информация о выбранном интервале времени не изменяется при выполнении каких-либо действий с графиком Расход. Это связано с тем, что в данным графике нет информации о времени.

При нажатии на кнопку Отчет выводится окно предварительного просмотра отчета о выбранном интервале времени. Этот отчет можно напечатать.

Снизу каждой панели графиков имеется ряд кнопок управления отображением:

  • 3D: если поставить галочку, то график на этой панеле будет 3-х мерным
  • увеличение масштаба
  • уменьшение масштаба
  • оптимальный масштаб
  • перемещение по графику влево
  • перемещение по графику вправо
  • печать графика

Если на обоих панелях отображены графики, зависящие от времени, то перемещение по одному из них или изменение масштаба одного вызывает соответствующее действие и со вторым. Таким образом, графики всегда синхронизированы по времени.

С помощью мыши также можно управлять отображением графиков:

  • для перемещения графика его надо "схватить" правой кнопкой мыши (нажать кнопку мыши и не отпускать) и передвинуть на желаемое расстояние, после чего отпустить (кнопку мыши).
  • для увеличения отдельной области графика следует эту область выделить мышью сверху-вниз и слева-направо.
  • для возврата к оптимальному масштабу следует выделить любую область графика снизу-вверх и справа-налево.

На графиках уровня топлива цветом подсвечиваются отдельные участки:

  • серый - выключено зажигание (уровень бортовой сети меньше 80% от номинального);
  • зеленый - заправка топлива
  • красный - слив топлива

На графике частоты оборотов двигателя горизонтальная желтая линия отображает установленную максимальную частоту оборотов двигателя на холостом ходу.


Информация об устройстве

При подключении носителя к компьютеру автоматически открывается окно "Информация", в котором (при успешном чтении данных из носителя) отображается информация о подключенном носителе и регистраторе, с которым данный носитель работал.

Также это окно можно открыть через пункт меню "Устройства"|"Информация об устройстве" или выбором пункта "Информация об устройстве" на вкладке "Устройства" скользящего меню слева в главном окне программы. При успешном чтении информации из носителя в зависимости от режима работы регистратора (задание/градуировка) производится поиск соответствующего задания или градуировки и, в случае успешного поиска, вывод нужного окна на экран. При возникновении ошибки чтения окно информации открывается с пустыми полями данных.

Раздел Информация о носителе:

  • Сер. номер носителя: серийный номер подключенного носителя информации.
  • Версия оборудования: версия носителя информации;
  • Версия ПО: версия встроенного программного обеспечения носителя.

Раздел Информация о регистраторе:

  • Серийный номер: серийный номер регистратора;
  • Автомобиль: гос. номер автомобиля, на котором установлен регистратор;
  • Дата установки: дата установки регистратора на автомобиль.

Кнопка "Инфо авто" открывает окно "Автомобили" с информацией об автомобиле, на который установлен этот регистратор (если есть такая информация).

Кнопка "Градуировка" открывает окно "Градуировка" с градуировочной характеристикой указанного автомобиля (если есть такая информация).

Кнопка "Техн. чтение" открывает окно "Технологические данные", которое используется для контроля правильности подключения и функционирования системы на конкретном автомобиле.

При нажатии на кнопку "Из файла...." производится чтение данных из файла протокола.

При нажатии на кнопку "Опрос носит." производится повторное чтение данных из носителя (при открытии данного окна чтение данных производится автоматически).

Закрыть окно можно, нажав на кнопку "Закрыть".


Носители информации

Носители информации предназначены для хранения и переноса информации, регистрируемой системой в процессе работы.

Все носители информации регистрируются в базе данных программы. Внесение информации о носителе производится автоматически при подключении к компьютеру с запущенной программой нового носителя. При этом оператору выдается запрос на подтверждение добавления информации о носителе в базу данных, утвердительном ответе на который в базу данных вносится информация, считанная с носителя.

Просмотреть, изменить или удалить информацию о носителях можно в окне "Носители", открываемого через пункт меню "Устройства"|"Список носителей" или выбором пункта "Список носителей" на вкладке "Устройства" скользящего меню слева в главном окне программы.

Для "ручного" добавления носителя в базу данных в окне "Носители" следует нажать кнопку "Создать". При этом форма переходит в режим ввода информации о новом носителе. Следует заполнить поля данных:

  • Серийный номер: указывается серийный номер носителя, приведенный на его корпусе или в его паспорте.
  • Находится в эксплуатации: признак использования носителя в текущее время.
Остальные поля заполняются автоматически по ходу выполнения операций с носителем.

После этого надо нажать кнопку "Добавить". Информация занесется в базу данных и отобразится в таблице. Для выхода из режима ввода без сохранения информации следует нажать кнопку "Обновить" или выбрать в таблицы другую строку.

Для изменения информации о носителе следует выбрать соответствующую строку в таблице и изменить информацию, после чего нажать кнопку "Изменить". Для изменения доступно только поле "Находится в эксплуатации". Для возврата к прежней информации (действует только до нажатия кнопки "Изменить") следует нажать кнопку "Обновить".

Для удаления носителя из базы данных следует в таблицы выбрать соответствующую строку и нажать кнопку "Удалить".

Окно "Носители" можно закрыть, нажав кнопку "Закрыть".


Регистраторы

Регистраторы устанавливаются на автомобиле. Для их дальнейшего использования в системе следует информацию о каждом регистраторе внести в базу данных программы. При подключении к компьютеру носителя с записанной регистрируемой информацией, программа автоматически считывает информацию о регистраторе, который писал эти данные, и производит поиск данного регистратора в базе данных. Если регистратор с таким серийным номером не найден, программа автоматически внесет информацию о нем в базу данных, предварительно запросив подтверждение оператора о выполнении такого добавления.

Добавить, просмотреть, изменить или удалить информацию о регистраторах можно в окне "Регистраторы", открываемого через пункт меню "Устройства"|"Список регистраторов" или выбором пункта "Регистраторы" на вкладке "Устройства" скользящего меню слева в главном окне программы.

В таблице окна "Регистраторы" отображаются все регистраторы, информация о которых имеется в базе данных программы. Если регистратор установлен на автомобиль и в базе данных имеется информация об этом, то в таблице отображается гос. номер данного автомобиля.

Для "ручного" добавления регистратора в базу данных в окне "Регистраторы" следует нажать кнопку "Создать". При этом форма переходит в режим ввода информации о новом регистраторе. Следует заполнить поля данных:

  • Серийный номер: указывается серийный номер регистратора, приведенный на его корпусе или в его паспорте.
  • Версия оборудования: указывается версия регистратора, приведенная на его корпусе или в его паспорте.
  • Версия ПО: указывается версия встроенного программного обеспечения, приведенная в его паспорте.

После этого надо нажать кнопку "Добавить". Информация занесется в базу данных и отобразится в таблице. Для выхода из режима ввода без сохранения информации следует нажать кнопку "Обновить" или выбрать в таблицы другую строку.

Для изменения информации о регистраторе следует выбрать соответствующую строку в таблице и изменить информацию, после чего нажать кнопку "Изменить". Поле "Серийный номер" недоступно для изменения. Для возврата к прежней информации (действует только до нажатия кнопки "Изменить") следует нажать кнопку "Обновить".

Кнопка "Освободить" удаляет "привязку" регистратора к конкретному автомобилю, после чего данный регистратор становится доступен (по информации в базе данных) для установки на другой автомобиль.

Для удаления регистратора из базы данных следует в таблицы выбрать соответствующую строку и нажать кнопку "Удалить".

Закрыть окно "Регистраторы" можно, нажав кнопку "Закрыть".


Резервное копирование и обмен информацией

При каждом считывании информации о задании из носителя создается архивированный файл протокола для резервного хранения информации и ее переноса с компьютера на компьютер. Файлы протокола создаются в каталоге, указанном в поле Каталог хранения файлов протоколов окна "Настройка". Архивированные файлы протоколов имеют имена формата:

ГГММДД_НННННННН_ххх.vpr,

где ГГ, ММ и ДД - соответственно год, месяц и день чтения данных из носителя;
НННННННН - гос.номер автомобиля;
xxx - порядковый номер файла протокола. Этой части имени может не быть, если существует только один файл протокола для конкретного автомобиля за данную дату.

Архивированный файл протокола содержит информацию о носителе, регистраторе, автомобиле и задании. В нем также хранятся значения регистрируемых параметров за отчетный период. Таким образом, данного файла достаточно, чтобы на другом компьютере получить всю необходимую информацию о данном задании (включая графики контролируемых параметров) и автомобиле (включая градуировочные характеристики).

Для внесения (обработки) информации из файла протокола необходимо открыть окно "Информация об устройстве" и нажать кнопку "Из файла...". После этого открывается стандартное окно выбора файла протокола, в котором следует выбрать нужный файл. После этого производится считывание данных их архивированного файла протокола и, при необходимости, добавление информации в базу данных программы. При этом, программа проверяет наличие информации в базе данных о носителе, регистраторе и автомобиле, указанных в файле; и при ее отсутствии выдает запросы на внесение такой информации в базу данных.

Далее производится поиск данного задания в базе данных, и (если задание не найдено - создается новое) открытия окна с детальной информацией о задании. Это задание, также как и считанное из носителя можно сохранить, сделать выполненным, просмотреть графики и т.д.

Если в базе данных найдена информация о требуемом автомобиле, то при обработке регистрируемых параметров, расчете статистических показателей, выводе графиков и т.д. используются данные об автомобиле из базы данных программы, а не считанные из файла протокола.


Технологический контроль

В процессе установки регистратора на автомобиль и в процессе эксплуатации системы могут возникнуть вопросы, связанные с контролем работы регистратора или носителя. Для проведения такого оперативного контроля можно воспользоваться окном технологических данных, которое открывается по нажатию на кнопку "Техн. чтение" окна информации об устройствах. Перед этим необходимо подключить носитель, имеющий регистрационные данные (работавший с регистратором) к компьютеру, так как при открытии окна технологических данных производится считывание протокола регистрации из носителя.

В этом окне в верхней части выводится около тысячи (или меньше, если их меньше в носителе) записей параметров; в нижней части окна - графическое представление регистрируемых параметров (также, около 1000 записей).

В таблице цветом подсвечиваются строки, соответствующие нажатию кнопки на регистраторе. Все напряжения приведены в вольтах, все счетные параметры - в количестве импульсов за период одной записи, температура - в градусах Цельсия.

В таблице приводятся следующие параметры:

  • №п/п: номер строки по-порядку
  • Кн: признак нажатия кнопки на регистраторе
  • U1: напряжение по первому измерительному входу; значение обычно используется как напряжение на датчике уровня топлива первого бака
  • U2: напряжение по второму измерительному входу; значение обычно используется как напряжение на датчике уровня топлива второго бака или напряжение на образцовом резисторе первого бака
  • U3: напряжение по третьему измерительному входу
  • Uборт: напряжение по четвертому измерительному входу; значение обычно используется как напряжение бортовой сети
  • RPM: количество импульсов по первому счетному входу; значение обычно используется как количество импульсов тахометра
  • S: количество импульсов по второму счетному входу; значение обычно используется как количество импульсов спидометра
  • Сч3: количество импульсов по третьему счетному входу
  • Сч4: количество импульсов по четвертому счетному входу
  • T: температура

Окно позволяет регулировать размеры всех графиков по желанию оператора, для чего нужно мышкой передвигать границы между графиками.

С помощью мыши также можно управлять отображением графиков:

  • для перемещения графика его надо "схватить" правой кнопкой мыши (нажать кнопку мыши и не отпускать) и передвинуть на желаемое расстояние, после чего отпустить (кнопку мыши).
  • для увеличения отдельной области графика следует эту область выделить мышью сверху-вниз и слева-направо.
  • для возврата к оптимальному масштабу следует выделить любую область графика снизу-вверх и справа-налево.

Окно можно закрыть нажатием на кнопку "Закрыть"


Водители

Информация о водителях используется программой при создании и поиске заданий. Для удобства пользования рекомендуется вносить всех водителей автомобилей, на которых установлены регистраторы, в базу данных программы.

Добавление, изменение, просмотр и удаление информации о водителях производится в специальном окне "Водители", которое открывается или выбором пункта меню "Водители"|"Список водителей", или выбором пункта "Водители" на вкладке "Водители" скользящего меню слева в главном окне программы.

По умолчанию, информация в таблице отсортирована по колонке "Фамилия", что индицируется символом "V" в заголовке этой колонке. Колонку сортировки можно изменить, щелкая мышкой по колонкам "Фамилия", "Имя", "Отчество". При этом символ "V" всегда отображает текущую сортировку. Колонка "№п/п" отображает порядковый номер строки в таблице и на сортировку не влияет.

В таблице сверху отображаются все водители, внесенные в базу данных программы. При выборе какой-либо строки в таблице информация о данном водителе отображается в полях ниже таблицы. Также, данная информация становится доступна для изменения.

Для добавления нового водителя в базу данных программы следует в соответствующие поля снизу таблицы ввести новые данные (фамилию, имя, отчество), после чего нажать кнопку "Добавить". Информация о новом водителе должна отобразиться в таблице.

Для изменения информации о водителе следует выбрать в таблице нужную строку, при этом информация отобразиться в полях снизу таблицы. Эту информацию можно изменить. Для сохранения измененной информации следует нажать кнопку "Изменить". Для возврата к прежней информации (действует только до нажатия кнопки "Изменить") следует нажать кнопку "Обновить".

Для удаления водителя из базы данных следует выбрать в таблице нужную строку, при этом информация отобразиться в полях снизу таблицы. После этого нажать кнопку "Удалить".

Кнопка "Обновить" предназначена для обновления информации в таблице и полях ввода.

Окно "Водители" можно закрыть, нажав кнопку "Закрыть".


Настройка

Настройка программы

Настройка программы заключается в задании некоторых параметров программы, конфигурирующих ее для конкретного пользователя на том или ином компьютере.

Настройка производится в специальном окне "Настройка", вызываемом пунктом меню "Файл"|"Настройка". В левой части окна настройки находится список разделов настройки. При выборе какого-либо элемента списка, в правой части окна открывается раздел, содержащий соответствующие параметры. Для закрытия окна с сохранением изменений следует нажать кнопку "Ок". При нажатии на кнопку "Отмена" окно закрывается без сохранения внесенных изменений.

  1. Раздел "Общие":
  • Используемый COM-порт: в этом поле следует указать СОМ-порт, к которому подключен адаптер. В списке отображаются наименования портов, установленных на данном компьютере.

  • Вторичная обработка данных: если установлен этот флажок, то при обработке полученных данных программой выполняется цифровая фильтрация (скользящее среднее). Данный параметр применяется при чтении данных из носителя информации и относится ко всем регистраторам, автомобилям и заданиям.

  • Период хранения файлов протоколов: устанавливает период, в течении которого хранятся файлы протоколов чтения информации с носителей. По истечению этого срока файлы протоколов автоматически удаляются программой.

  2. Раздел "Каталоги"
  • Каталог хранения файлов данных: в этом поле следует указать (ввести или выбрать с помощью кнопки справа) каталог, в котором будут храниться файлы с данными завершенных заданий. По умолчанию программа настраивается на каталог "Data" в каталоге программы.

  • Каталог хранения файлов протоколов: в этом поле следует указать (ввести или выбрать с помощью кнопки справа) каталог, в котором будут храниться файлы протоколов чтения информации с носителей. По умолчанию программа настраивается на каталог "Prot" в каталоге программы.

  3. Раздел "Интерфейс"
  • Показывать надписи кнопок: если установлен этот флажок, то в форме графиков кнопки выбора графиков будут отображать, кроме пиктограмм, еще и подписи.